Ticket #9 (closed bugs: fixed)

Opened 14 years ago

Last modified 14 years ago

TURL returned without having the file restored from tape

Reported by: patrick Owned by: patrick
Priority: major Milestone:
Component: srm Keywords: SURL, TURL, restore
Cc: Sub Version: any

Description (last modified by patrick) (diff)

Details

There is no restore request to the PoolManager if SRM returns an TURL and the file is not on disk. The problem was initially reported by LHCb but could be confirmed by the Test Suite. For now the LHCb is urging the Tier I's to open the gsidcap door in order to do the prestage with dccp -P.

Further Information

Developers have different opinions on the cause of this issue.

Problem solved (theoretically)

Timur "I found that the initial state of the pin was for some reason set to PINNED, which prevented the pin from ever doing the presaging. The code if fixed and committed to both heads of 1.7 and trunk. Please run your tests again. Hope this will be included in the next release."

Needs to be checked ....

Change History

comment:1 Changed 14 years ago by patrick

  • Status changed from new to assigned
  • Description modified (diff)

comment:2 Changed 14 years ago by patrick

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with 1.7.0-35

Description by Timur I looked at the pin manager. I found that the initial state of the pin was for some reason set to PINNED, which prevented the pin from ever doing the presaging. The code if fixed and committed to both heads of 1.7 and trunk.

Note: See TracTickets for help on using tickets.